Testing Android Hybrid App on Mac Results in -- No Chromedriver found that can automate Chrome '78.0.3904'

I am testing an Android Hybrid App on Mac with IntelliJ Java. I have an instance of AndroidDriver. It works with the native app. But when I try to change the context with the following, I get an error (No Chromedriver found that can automate Chrome ‘78.0.3904’):


The version of chrome that I have installed is 83.0.4103.97

In terminal I see the version of chrome drive is 2.20

What do I need to do to get around the version issue? I download the 78.0.3904 version of chrome driver, but I did not figure out how to get Appium to find it.

Go to this site: Appium Chromedrivers

You’ll find plenty of information about chromedrivers. Check the chromedriver for your version, i.e. 83.0.4103.97

Then run this command from the command prompt (Replace 2.37 with whatever version you find on the site, it’ll look similar)

npm install appium --chromedriver_version=“2.37”

If this doesn’t work, it’s kind of a brute force method which worked for me, where you get all the latest chromedrivers

appium --allow-insecure chromedriver_autodownload

Remember, the above command, needs to be passed in the command prompt when the appium server needs to be started. Whatever chromedrivers will be needed during the session will be downloaded automatically.

Thank you for your reply. I found the version to set on the following page:

But my version of chrome is not listed: 83.0.4103.97

I do see a pattern in that the latest versions are the same version. Thus, I attempted the following:
npm install appium --chromedriver_version=“83.0.4103.97”

This results in the following:
updated 1 package and audited 679 packages in 3.151s

But that did not resolve the above issue.

I tried running the following:
appium --allow-insecure chromedriver_autodownload

he result was the following:
-bash: appium: command not found

This may be because I am using Appium desktop. Do you know how I can change this setting for Appium desktop?

There is a course on linkedin learning that I am using to reproduce the above issue:

  1. You can download the exercise files.
  2. Then uncomment setUpAndroid()
  3. Comment out setUpIOS().
  4. Then run testHybridApp()
    Results: the issue above displays. – No Chromedriver found that can automate Chrome ‘78.0.3904’
    Expected results: Test passes

Hi @Charles_Teague,

Just run your Appium like this:

appium --allow-insecure chromedriver_autodownload

This command will automatically download the needed version of Chromedriver.

Thank you. The result of that command follows:
-bash: appium: command not found

This is mostly because I am running Appium desktop.

Is there something I need to put into my system path in order to make the “appium --allow-insecure chromedriver_autodownload” command work?

I installed the command line version of Appium and ran it per the above command. Here is the result:
No Chromedriver found that can automate Chrome ‘69.0.3497’

I updated chrome on the phone, and now I get the following result when running the test:
No Chromedriver found that can automate Chrome ‘83.0.4103’

OK, I updated chrome on an emulator and the Mac to the latest. I ran the above again. It did not resolve the issue, but something may have been installed. Then I ran the following:
appium --chromedriver-executable /Users/charlesteague/chromedriver/chromedriver

Then I allowed chromedriver to run by going to settings->Secure & Privacy and click open.

Then I run it again and it finally worked.

Thanks for all of the help.