The unit test failed at 8db0122

I cloned Appium lasted commit (8db012255594acf55cc88ab7fd20827a68ba7496) to observe how Appium works. After I install the package and build,
I run npm run test and. npm run test:unit I found the error

but my friend use Macbook M2 can run all the tests passed. ( I use Mac intel core i7)

I went back to the commit 6 days ago (f62db4b26d94475d9cdfa3e6fcfc107f3be73b65) and run the test, all the tests passed

Does anyone face this issue before and knows how to fix it?

I tried running unit test at commit d160e3959e583038150aab4a03643ca30766fba8

and got this error

 when the extension data is missing an `appiumVersion` field
          when an upgrade is not available
            1) "before each" hook for "should resolve w/ an appropriate warning"

I am taking a look into the test case as well.

I tried to debug in vscode with this configuration in launch.json

      "type": "node",
      "request": "launch",
      "name": "Mocha Tests",
      "program": "${workspaceFolder}/node_modules/mocha/bin/_mocha",
      "args": [

But got these error

import {promises as fs} from 'fs';

SyntaxError: Cannot use import statement outside a module