Trying to run test on a real device

The simulator test was run on iPhone and the device is an iPad.
I did manage to succesfully run on simulator. I did edit it a bit to run it on the simulator. When I tried to run the same test on the device when it tries to find the ‘q’ element instead of finding it it ends up writing ‘q’ after the loaded url, then it writes sauce labs (still in the url) and then ‘qq’ (where did they come from :open_mouth: )

Edit: I saw in the log:
[iOS] Attempted to get a list of webview contexts but could not connect to ios-webkit-debug-proxy. If you expect to find webviews, please ensure that the proxy is running and accessible

I did run the proxy:
$ ios_webkit_debug_proxy
Listing devices on :9221
Connected :9222 to Robert’s iPad (aef2b9be73953af7a0596f14a00b00837e1cf2a3)

Is there anything more to it. How can I confirm that it it accessible?

Well all this time and the problem was I ran the proxy on the wrong port. After I circled back to the documentation I saw that I should run it on :27753.