Unable to authorize Appium.app

I am using Appium.app. When I run the example I get:

A new session could not be created. (Original error: We don’t have write access to /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator7.1.sdk/Applications/MobileSafari.app, please re-run authorize as naderelziq)

I tried changing the permissions for my user to “Read & Write” for MobileSafari.app. I also tried doing a chmod 777 on MobileSafari.app. Neither helped.

The setup guide says: “If you are running Appium.app, you can authorize iOS through the GUI.” How do I do that?!??!

if you are working on Simulator, please execute the authorize command for Simulator.

sudo authorize_ios

I get

sudo: authorize_ios: command not found

I installed Appium using node.js and I get the same result.

facing the Same issue on iOS …
Any help?

Move the app to your home folder. (Some where under ~/) I use Download for my .app with simulator, works fine.

Hey Alex,
Thanks for the reply.
What u mean by " I use Download for my .app with simulator"??Din get u

  1. copy .app folder into “~/Downloads” from your build folder (somewhere in /Applications/…)
  2. Point to ~/Downloads/xxx.app in Appium.
  3. Launch.

I noticed nelziq is using system app. You cannot instrument system app without certificate from original builder.

Hey Alex,Thanks a lot buddy , i am new to appium , can you please let me know how to point appium to ~/Downloads/xxx.app

And repeat: No way to instrument system apps.

Thanks a ton Dude, I’l try this…:slight_smile:

Hi Alex,

I tried the steps which you suggested and m getting these errors.
I have prelaunched the Application"Mobile Safari".
M adding the snapshots below

Any one faced this issue?

1 Like

Anyone facing this issue could first check with Appium Doctor on the GUI- Checks if all the appium settings are done correctly.