Unable to click on Signin button

after entered the credentails, there is sign in button, I have used normal click command/ tap functinoality to click dat particualr button, script is getting passed but clicking is not happenining, Any alertnate methods to click on this particualr button

strong text
please find the attached SS…

add you code for help.

Hi guys, seems, I have the same issue.
I am QA and trying integrate the Appium into my pet-project in the first time, I trying to click on the Next button programmatically using appium library. This button should brings me to the next screen, but nothing happens. Please, take a look at the code, will you have any ideas about why it doesn’t work, Thanks)
Note: I have native app for AndroidTV devices. I installed him to Android_TV_720p_API_28 emulator.
My code: myCode.txt (1.9 KB)
Appium-server logs : appium-server-logs.txt (33.7 KB)
pom file: pom.txt (1.3 KB)

I discussed with familiar developer, and he said that Next button is located in the different activity named AppConfiguratorActivity.
So, when I switch to this activity (AppConfiguratorActivity) and tried click on the Next button, I receive error: error_appium-server-logs.txt (30.0 KB)
new code(tried switch to AppConfiguratorActivity): newCode.txt (2.2 KB)

@117 android:exported=“true” should be in AndroidManifest.xml
details can be found on below link:

1 Like

add also output on thi screen with:


here we can see your “Next” element and it attributes.


@Aleksei Hi! How you think, Am I took the right locator?
page source: PageSource.txt (11.0 KB)

MobileElement el1 = (MobileElement) _driver.findElement(MobileBy.AndroidUIAutomator("new UiSelector().resourceIdMatches(\".*guidedactions_item_title\").text(\"Next\")"));

How element tree looks in UIAutomatorViewer: dump.txt (9.3 KB)

el1 code looks OK.
but in " myCode.txt" i do not see TAP action on el1.

e.g. use:

TapOptions tapOptions;
try {
       tapOptions = new TapOptions().withElement(ElementOption.element(el1));
       new TouchAction(driver).tap(tapOptions).perform();
} catch (Exception e) {

Also in Developer Android Menu enable “Show touches” -> it will help you to see where TAP happens.

1 Like

@Aleksei Exactly, you are right, I stupid, I forgot that need to click/tap on the button :sweat_smile:

Hi guys! Thanks for replies
So, I used to TAP action code that provided @Aleksei, but I still cannot bring to the next screen.
code: code.txt (2.4 KB)
appium-logs: appium-server-logs.txt (31.7 KB)
XML Source to Clipboard: XML Source to Clipboard.txt (11.0 KB)

Please, attention pay, I enabled “Show touches” as Aleksei told me. And what I see, if I tap on Next text —> I cannot go to the next screen, like that:

but, if I move a focus to the right side and make tap —> I can go to the next screen, like that:

May be, it linked to wrong locator:
MobileElement el1 = (MobileElement) _driver.findElement(MobileBy.AndroidUIAutomator("new UiSelector().resourceIdMatches(\".*guidedactions_item_title\").text(\"Next\")"));

I asked familiar developer, and he said that probably need to tap/click on GuideActionItemCantainer:

but I don’t see GuideActionItemCantainer in SourcePage.

Double check that you can reproduce this manually. If should be reproducible also manually. It just a bug in such case.