Unable to get IPA file of an application. Is there any alternative to automate an iOS app?


Firstly, am not really sure if I am posting this on the correct thread, so apologies if not.

I would appreciate if anyone could help me tackle an impediment I’m facing in automating an iOS app.

  1. The app in question is a third-party enterprise app which is not developed by our organisation but we use it as part of an end-to-end cycle. Users enter data in the system using this app and then things move forward
  2. This is an iOS only app which could be downloaded by logging into the third-party company’s website and not via the App Store
  3. The app gets successfully installed on my iOS device but for some reason I am unable to get the IPA of this app transferred to my mac. I tried the usual iTunes method and after looking at some blogs tried using iTools as well. But no go.
  4. Apps installed pre and post this particular apps have no issues in having their IPA transferred to the mac

I would appreciate if anyone could suggest a workaround to automate this app using Appium or if there is any way to get the IPA transferred to the Mac, or if anyone is aware of what could be the possibility for the IPA not getting transferred. I have tried on 2 Mac machines and 4 iOS devices with no luck. Any suggestions would be greatly appreciated. Cheers!

Is this third party website publicly accessible and could you share the URL?

Hey Wreed! Thanks for replying. The URL is test.salesforce.com which is publicly available, but unfortunately I cannot share the login credentials. This is the app - https://www.veeva.com/resources/veeva-crm-mobile-veeva-clm-product-brief/