Unable to identify elements in Appium inspector

I am using Appium 1.6.5
Device : iPod
iOS version : 10.3.3

when i launch the application through Appium, i am unable to identify elements using Appium inspector.
I click on any objects, the whole frame is getting selected.so i am not able to proceed with the automation.

Please help me out with the solution

Please find the attachment

Try to reopen appium & check and what do you see if you click on the other two ‘XCUIElementTypeWindow’? Manually traverse through the list.

If you are still not able to find them, this might be an issue with app. Please check with your development team. I faced a similar problem where half of my app is not accessible, the developers fixed it later.

Hi Venkatesh, Thanks for your reply
I tried this for n number of times, each time i open the inspector, i experience the same behaviour,

  • On click of the first XCUIElementTypeWindow , again the frame is getting selected
  • On click of second XCUIElementTypeWindow , the status bar information is displayed - able to identify only
    status bar objects

Refer the attachment

Then its an app problem, you should get in touch your app dev to fix this.

are you able to find the solution???

what exactly might be the issue

Duplicate of Ios: Can't see Elements I can interact with

I am also facing the same issue on a web based mobile app on Android. Same app is working with other devices. Does anyone have a solution for this?

Try the below capabilities
capabilities.setCapability(“appPackage”, “your app package”);
capabilities.setCapability(“autoLaunch”, false );

I am facing same issue, When I am selecting an element, whole frame highlighted. Unable to select any element by using Appium inspector. Does any one has solution for this issue.

Try this:
capabilities.setCapability("enableMultiWindows", true);