Unable to install iOS app after updating to Xcode 8.0 and ITunes 12.5.1

Hi there,

I’m having issues this morning installing iOS apps using Appium on iOS9 devices. I updated iTunes (12.5.1)/XCode (8.0) to the latest versions after I noticed issues with iOS10 devices not working. Then I tried my iOS9 device and the app now fails to install. I tried reverting to previous versions of ITunes/XCode but no luck. I’ve also tried reinstalling Appium. When I click on Inspector I get the following error.

[MJSONWP] Encountered internal error running command: Error: Installing /var/folders/5v/38ljlsk974l72gm966w74v1m0000gp/T/2016814-1001-549l4r/Payload/MyApp.app failed
at /Applications/Appium.app/Contents/Resources/node_modules/appium/node_modules/appium-ios-driver/node_modules/node-idevice/main.js:159:6
at ChildProcess.exithandler (child_process.js:193:7)
at emitTwo (events.js:100:13)
at ChildProcess.emit (events.js:185:7)
at maybeClose (internal/child_process.js:850:16)
at Socket. (internal/child_process.js:323:11)
at emitOne (events.js:90:13)
at Socket.emit (events.js:182:7)
at Pipe._onclose (net.js:475:12)

If anyone has an idea how to solve the problem, that would be great.


I’m facing the same error, even though I only updated iTunes 12.5.1.

Before updated iTunes 12.5.1, it was fine with Appium 1.5.3, Xcode7.3.1, iPhone6 (iOS8.4), Mac OS Yosemite (10.10.5).

So does anyone have a workaround or a solution? Thank you.

I found a way!

It seems that we need to update ios-webkit-debug-proxy to ver1.7.

Also maybe we need to update libimobiledevice.

So what we have to do is,

  1. brew uninstall ios-webkit-debug-proxy && brew install ios-webkit-debug-proxy
  2. brew uninstall libimobiledevice && brew install --HEAD libimobiledevice

Thenks jormungand it is works

Thanks very much it worked :slight_smile:

jormungand You Rock!

Fixed the issue.

What is strange is that I didn’t upgrade the iTunes manually (Can it be that it is automatically upgraded?)


Thanks very much :slight_smile::slight_smile:

Thank you very much! :slight_smile:

Thanks Man…this worked for me