Unable to launch appium server from command propmt on mac due to missing file appium.js in “Appium.app/Contents/Resources/node_modules/appium/bin/” in Appium 1.5.3

Hope your doing well !

I have few queries that i want to share with you. Here are the one’s.

Currently I’m working on multiple device for IOS both parallel/ sequential execution. Initially i was installed Appium 1.5.3 and trying to trigger the appium server for each device with the path location Appium.App/Contents/Resourses/node_modules/appium/bin/appium.js but it got failed with below error.

om.github.genium_framework.server.exception.InvalidAppiumJSFilePathException: The file you provided was not found on your HDD. You provided the following file path: /Applications/Appium.app/Contents/Resources/node_modules/appium/bin/appium.js

I have checked and found that appium.js does not exist in …/bin folder on my mac. It doesn’t exist in any other folder either.

I just found out via another post , found the appium.js file in “/Applications/Appium.app/Contents/Resources/node_modules/appium/lib”
I have changed the code as below but it is still failing.

23-06-2016 10:44:31 INFO - Failed to start Appium server due to following reason: The server didn’t start after 30000 milliseconds with error:
(function (exports, require, module, __filename, __dirname) { import _ from ‘lodash’;

SyntaxError: Unexpected token import
at exports.runInThisContext (vm.js:53:16)
at Module._compile (module.js:387:25)
at Object.Module._extensions…js (module.js:422:10)
at Module.load (module.js:357:32)
at Function.Module._load (module.js:314:12)
at Function.Module.runMain (module.js:447:10)
at startup (node.js:146:18)
at node.js:404:3

Someone advised to use main.js file instead of appium.js, and I tried that too but it also failed.

Due to this multiple issue , i couldn’t launch the appium server via command prompt in appium 1.5.3.

Later with forum advise i downgraded to Appium 1.4.13 and i can able to successfully launch the Appium through command prompt with location path Appium.App/Contents/Resourses/node_modules/appium/bin/appium.js and achieved IOS multiple devices and able to launch parallel/sequential without any issue.

Please let me know if you have achieved IOS multiple devices in Appium 1.5.3.

In the later versions of Appium (I believe it was 1.5+) Appium.js was replaced with a new file in a different location name main.js.

If you install 1.5.3 and try something like node /Applications/Appium.App/Contents/Resourses/node_modules/appium/build/lib/main.js I believe your tests will start working again.

NOTE: The folder path to the main.js file is different than the old appium.js location.

Hope that helps.

Know i tried that way , and still getting an error message " -bash: appium: command not found
[1]+ Exit 127 appium

I’m getting same error [1] 3790
-bash: appium: command not found
[1]+ Exit 127 , can you share your thoughts