Unable to launch ios7 simulator from appium using xcode6

Hi i am new to appium, app file was build from xcode6.
Had given app path in appium with iPhone5 and ios7.0 and xcode as xcode6

I want the app to be launched on ios7 simulator but when i start appium its launching me ios8 simulator can anyone please help me

First make sure you have the UDID registered for your development org. I make sure this is all working by building and deploying the app to my tethered device.

If that isn’t working you need to paste the Appium logs here or it will be hard to help you. When pasting something long I like to quote it with the </> to make the thread easier to read. Also when I start Appium to debug iOS issues I’ll add --show-ios-log to get better logs and try both with and without the --native-instruments-lib flag. But that native instruments flag never helped me, it is just an easy thing to try.

Have you tried forcing it to start with iOS 7.x simulator?

@ento: Yeah had kept the same options and tried to launch but it’s still launching ios8 simulator not ios7

Silly question. Can you access an iPhone5.x with iOS7.x from your iOS Simulator?

(If that is so, you shouldn’t have issues starting your app from it.)