Unable to launch safari browser in iPhone simulator using Appium v1.6.4 beta

Hi All,

I have set below environment:

Ruby language
Mac OSX 10.11.6
Xcode 8.0
Appium v1.6.4 beta
iPhone simulator

I am trying to automate mobile browser safari in iPhone simulator. Command prompt displays below error on executing code. Also simulator launches safari browser and immediately closes without performing any action. Please advice on this.

Encountered internal error running command: TypeError: this.nativeTap is not a function
at XCUITestDriver.navigate$ (…/…/…/lib/commands/context.js:415:18)
at tryCatch (/usr/local/lib/node_modules/appium/node_modules/babel-runtime/regenerator/runtime.js:67:40)
at GeneratorFunctionPrototype.invoke [as _invoke] (/usr/local/lib/node_modules/appium/node_modules/babel-runtime/regenerator/runtime.js:315:22)
at GeneratorFunctionPrototype.prototype.(anonymous function) [as next] (/usr/local/lib/node_modules/appium/node_modules/babel-runtime/regenerator/runtime.js:100:21)
at GeneratorFunctionPrototype.invoke (/usr/local/lib/node_modules/appium/node_modules/babel-runtime/regenerator/runtime.js:136:37)


Create safari launcher app in ur xcode project and try its hope it will helps u

Thanks Pradeep. I have created safari launcher app in xcode project and tried it but the same result, safari browser launches & immediately closes without performing any action.Also displays same error TypeError: this.nativeTap is not a function

Can u share ur code so it’s easy to understand.

after created project try to run build in xcode after ur build success than u try with appium.

Note:- make sure ur build succeed successfully