Unable to locate an element using appium inspector

Unable to locate an element which is present on mobile app
Example: X-button present on pop up window but using appium inspector i’m unable to locate it.
Also, I have dig in to app source for that element but unable to find the element in view source.

Please suggest what could be the reason?

FYI: It was working in previous app builds but not now.

if you are with Android in many cases you need to add capability:

capabilities.setCapability("enableMultiWindows", true);

Thanks @Aleksei i’m trying this solution and will get back to you

It did not worked for me :slightly_frowning_face:

share more info:

  1. page source here -> https://gist.github.com/
  2. screenshot
  3. capabilities

HI @Aleksei I’m bound to not share the screenshots and page source.

is there a possibility of issue with appium inspector only, as the same element i was able to locate using inspector in previous builds.
Please confirm.

I do not know. I do not use Appium GUI inspector. I prefer user page source instead.

hi @Aleksei what are the steps to follow for android and ios to check user page source.
It would be very helpful for me as well.

as usual:

// Java

// on needed screen
System.out.println(driver.getPageSource());
2 Likes

I am also facing the same issue, Is your issue resolved? ow did you solved it?

It was working on previous build but not anymore

Even i am facing the same issue , My colleague able to find the elements from his appium inspector, For me same Elements are not able to locate using appium inspector.