Unable to open iOS application using appium 1.6 in real device

Hi all,

I’ve fixed all the error messages found from appium_server.log. Application
installs in real iOS device (iPhone 6, iOS 10.0.2) but it is not opened. appium_server.log
does not provide me any info. It seems to be stuck.

I’m using robot framework + appium library. From robot log i can see that it stays in Open Application keyword.

Any idea what might be the issue? Is there a way to get better logs to see what is going on?

Mac OS X El capitan
Appium 1.6
Robot Framework + appium library
iPhone 6 iOS 10.0.2

Please list capabilities and software details ?

hi @pavanbachu,

Open Application
... 	http://localhost:${APPIUMSERVERPORT}/wd/hub 	platformName=${PLATFORM_NAME} 	platformVersion=${PLATFORM_VERSION}
... 	deviceName=${DEVICE_NAME} 	app=${APPLICATION_PATH} 	udid=${UDID}
...     realDeviceLogger=//usr//local//lib//node_modules/deviceconsole/deviceconsole 

Here is my Open Application -keyword parameters. For xcuitest i’ve added realdeviceLogger and hardcoded the correct path for testing purposes. I’m not sure what kind of software details are you looking for?

@Kazeva can you share the appium and robot logs if you dont mind.

Hi, @Sethu

Here are my logs:

node:10061) DeprecationWarning: os.tmpDir() is deprecated. Use os.tmpdir() instead.

20161110 14:20:19.798 - INFO - ±-- START KW: AppiumLibrary.Open Application [ http://localhost:${APPIUMSERVERPORT}/wd/hub | platformName=${PLATFORM_NAME} | platformVersion=${PLATFORM_VERSION} | deviceName=${DEVICE_NAME} | app=${APPLICATION_PATH} | udid=${UDID} | realDeviceLogger=/usr/local/lib/node_modules/deviceconsole/deviceconsole ]

console view:
Appium is using port number 53443

Starting Appium server…
Appium server up and running.


Nothing happens after this. Application is installed but not launched

@Kazeva have you mentioned the location of xcconfig file location ? You should make sure that the WebDriver agent(In latest appium) needs to be signed with developer account

I am also unable to launch the iOS application using appium 1.6 on real devices.

My webdriveragent project is started on device after that it is unable to run any tests and I am not getting any error message.

can some one help me on this.

Below are my configuration details
ios Device : iphone6s with 10.1 iOS

My appium logs:
appium &
[1] 8920

WS103309:~ srivastava4f0z$ (node:8920) DeprecationWarning: os.tmpDir() is deprecated. Use os.tmpdir() instead.

[Appium] Welcome to Appium v1.6.0 (REV 1d66cdd3ade841c6b7cd8a71d4b71d5426d00a58)

[Appium] Appium REST http interface listener started on

[HTTP] --> POST /wd/hub/session {“desiredCapabilities”:{“app”:"/Users/srivastava4f0z/Documents/swathi/ABCMeTabletsAutomation/src/test/resources/com/abc/mobileApps/abcme.ipa",“platformVersion”:“10.1”,“automationName”:“XCUITest”,“bundleId”:“au.net.abc.abcme”,“udid”:“15eb7de5c880d3c6062eb2a43bfb53af06472d28”,“platformName”:“iOS”,“deviceName”:“ABC’s iPhone”,“autoAcceptAlerts”:true}}

[MJSONWP] Calling AppiumDriver.createSession() with args: [{“app”:"/Users/srivastava4…

[Appium] Creating new XCUITestDriver session

[Appium] Capabilities:

[Appium] app: ‘/Users/srivastava4f0z/Documents/swathi/ABCMeTabletsAutomation/src/test/resources/com/abc/mobileApps/abcme.ipa’

[Appium] platformVersion: ‘10.1’

[Appium] automationName: ‘XCUITest’

[Appium] bundleId: ‘au.net.abc.abcme’

[Appium] udid: ‘15eb7de5c880d3c6062eb2a43bfb53af06472d28’

[Appium] platformName: ‘iOS’

[Appium] deviceName: ‘ABC’s iPhone’

[Appium] autoAcceptAlerts: true

[debug] [XCUITest] XCUITestDriver version: 2.0.26

[BaseDriver] Session created with session id: 2d5588ee-9833-498f-8826-5784b439f256

[debug] [XCUITest] Xcode version set to ‘8.1’

[debug] [XCUITest] iOS SDK Version set to ‘10.1’

[debug] [XCUITest] Available devices: 15eb7de5c880d3c6062eb2a43bfb53af06472d28

[debug] [XCUITest] Creating iDevice object with udid 15eb7de5c880d3c6062eb2a43bfb53af06472d28

[XCUITest] Determining device to run tests on: udid: ‘15eb7de5c880d3c6062eb2a43bfb53af06472d28’, real device: true

[BaseDriver] Using local app ‘/Users/srivastava4f0z/Documents/swathi/ABCMeTabletsAutomation/src/test/resources/com/abc/mobileApps/abcme.ipa’

[debug] [BaseDriver] Copying local zip to tmp dir

[debug] [BaseDriver] Unzipping /var/folders/yg/9m75_q9j4d7dzqrjgcjfjfw9sx6hwn/T/20161011-8920-1hc8gmz.qrp1glow29/appium-app.zip

[debug] [BaseDriver] Testing zip archive: /var/folders/yg/9m75_q9j4d7dzqrjgcjfjfw9sx6hwn/T/20161011-8920-1hc8gmz.qrp1glow29/appium-app.zip

[BaseDriver] Unzipped local app to ‘/var/folders/yg/9m75_q9j4d7dzqrjgcjfjfw9sx6hwn/T/20161011-8920-1hc8gmz.qrp1glow29/Payload/abcme.app’

[debug] [XCUITest] Checking whether app is actually present

[debug] [iOSLog] Attempting iOS device log capture via libimobiledevice idevicesyslog

[debug] [iOSLog] Found idevicesyslog: ‘/usr/local/bin/idevicesyslog’

[XCUITest] Setting up real device

[debug] [XCUITest] Stdout from app isInstalled check: […] Waiting for iOS device to be connected

[…] Using iPhone 6s ‘ABC’s iPhone’ (15eb7de5c880d3c6062eb2a43bfb53af06472d28).


[debug] [XCUITest] App is installed.

[debug] [XCUITest] Full reset not requested. No need to install.

[XCUITest] Using default agent: /usr/local/lib/node_modules/appium/node_modules/appium-xcuitest-driver/WebDriverAgent/WebDriverAgent.xcodeproj

[XCUITest] Using default bootstrap: /usr/local/lib/node_modules/appium/node_modules/appium-xcuitest-driver/WebDriverAgent

[XCUITest] Launching WebDriverAgent on the device

[debug] [XCUITest] Carthage found: /usr/local/bin/carthage

[debug] [XCUITest] Beginning test with command ‘/usr/local/lib/node_modules/appium/node_modules/appium-xcuitest-driver/bin/run-xcodebuild.sh --project /usr/local/lib/node_modules/appium/node_modules/appium-xcuitest-driver/WebDriverAgent/WebDriverAgent.xcodeproj --scheme WebDriverAgentRunner --destination id=15eb7de5c880d3c6062eb2a43bfb53af06472d28’ in directory ‘/usr/local/lib/node_modules/appium/node_modules/appium-xcuitest-driver/WebDriverAgent’

[XCUITest] Waiting for WebDriverAgent to start on device

[XCUITest] The real device logger ‘idevicesyslog’ was unable to start log capture. Please try installing ‘deviceconsole’ (‘npm install -g deviceconsole’) and specify the path to it using the ‘realDeviceLogger’ capability.

[debug] [XCUITest] Log file for xcodebuild test: /Users/srivastava4f0z/Library/Developer/Xcode/DerivedData/WebDriverAgent-brdadhpuduowllgivnnvuygpwhzy/Logs/Test/5A8917B4-C6E7-4897-A443-CF1EF60F8FB4/Session-WebDriverAgentRunner-2016-11-11_135451-ngo2zR.log

@swathi Please install the realDeviceLogger and pass it as one of the capability along with its path

Hi @pavanbachu,

i believe this is now the issue I’m having. I tried to use Jenkins build that worked
with uiautomation framework. Is there any place where all needed actions are explained
clearly? Person who has lot more expertise building using Xcode did not really understand how this will work on CI-systems. Actually i’m not familiar with Xcode at all. Previously i just took Jenkins build, installed into device and started automating.

What are the steps are needed to be done? Do we need to build webdriveragent (each time) and install it in the real device before we can start appium? Each computer that will run appium+xcuitest must have Xcode building capabilities? How is this all done on CI-enviroments where we have multiple real iOS devices installed?

@Kazeva I would first recommend you to run test using eclipse so as to confirm if you are able to open the app. Reply me back with the set of capabilities you are using now and also the platform i mean iOS version , MacOS version