Unable to register IOS developer account to add new phone on Appium Studio

I have a problem registering a paid IOS developer account in Appium Studio. It returns the error message below. I am registering with an Apple ID that has a paid Apple developer account and I am using an App Specific Password when registering. I have tried this on 3 different machines, 2 in the UK and 1 in USA and all get the same error. I have tried this on two different Apple Developer accounts and both get the same error.

Failed to add developer account with appleid: [email protected] and teamid: XXXXXXXXX reason: Bad response from server.
200: OK
Server says: Authentication Error. Xcode 7.3 or later required to continue developing with your Apple ID. (3019)
Please make sure you are not using a free account, as it is not supported.

This is running on

  • Appium version: 22.1.8625
  • OS: Windows 10

The Appium log file reports and ERROR Initial CSR failed in addition to the message that is displayed in the Appium Studio dialog box. I have put a copy of the Appium Log file at the following location:

A bit wrong forum.
Correct -》https://appium.experitest.com/

Apologies, thanks for the info, but, I never get an email confirmation for my account sign up from that forum. Have tried several emails and checked app spam. Do you have any contact there I could message/email to get an account set up? Thanks again.

Sorry no contact. Never used it.

Appreciate your time Aleksei, thank you very much,

um, are you still on xcode 7? Are we not on xcode version 11 now?
Assume the error message is jut missleading - can you build the project fine in xcode using the team id you got from the platform?

Agree with @Conrad_Braam. Error message is dead on.

Probably won’t find many with AppiumStudio on this forum though. Sorry you aren’t able to get an email from AppiumStudio support. Maybe check spam/junk folder.

@Conrad_Braam, @wreed Thanks for replies. This is using the Appium Studio product where I do not have control over the XCode version being used, it is reported from the Appium Studio servers.

Spam folders all checked for any related emails but none found having tried several email accounts. Thanks again for replying.

1 Like