Unable to run Android iphone simulator

Hi All
I have created a docker image to hold an appium server on a docker container.

docker run --privileged -d -p 4723:4723 -v /dev/bus/usb:/dev/bus/usb --name container-appium appium/appium

I see the appium server running with below logs
docker exec a3db57777964 appium -view

Appium server seems running

When i ran a selenium script below opening a simple script opening a google then im getting error,
Unable to find adb devices.

DesiredCapabilities capabilities = new DesiredCapabilities();

	capabilities.setCapability("deviceName", "Nexus 6");
	capabilities.setCapability("platformVersion", "8.1.0");
	capabilities.setCapability("platformName", "Android");
	//URL url= new URL("");
	URL url= new URL("");
	//URL url= new URL("");
	 driver = new AndroidDriver(url, capabilities);
	driver.manage().timeouts().implicitlyWait(30, TimeUnit.SECONDS);


First, there is no such thing. You may be talking about an Android Emulator, or an iPhone Simulator, but the thing that you name does not exist.

Second, your question is very Docker specific, I’m going to reword it here to get to the heart of the problem:

“How do I access an iPhone/Android device from a docker instance?”

When you put it this way, you will probably realize that this is not an Appium specific problem, and it would probably be more appropriate to ask that question here:

Finally, this:

You know that’s not good enough, right? It’s running or it’s not. Seems running isn’t going to get this done.

So to reiterate, you need to:

  1. figure out how to access your device from docker and make absolutely certain that it’s working
  2. figure out whether Appium server is working. for real.
  3. ask good questions in the appropriate forums if the above is not working
  4. come back and post Appium specific questions
  5. it would be great if you could post a blog or something explaining how you solved this. it would probably help someone else.

If you can do these things, you’ll probably get where you want to go. Good luck to you.

It’s just one of many miss-questions on this forum. More topics need answers like this. :slight_smile: