Unable to start appium server


I was using appium yesterday to automate and android app and it was working fine. Today, I tried to restart the appium server and i am getting the following message:

Starting Node Server
usage: main.js [-h] [-v] [–shell]
main.js: error: argument “–intent-args”: Expected one argument. null
[–localizable-strings-dir LOCALIZABLESTRINGSDIR] [–app APP]
[–ipa IPA] [-U UDID] [-a ADDRESS] [-p PORT]
[-k] [-r BACKENDRETRIES] [–session-override] [–full-reset]
[–no-reset] [-l] [-lt LAUNCHTIMEOUT] [-g LOG]
[–log-level {info,info:debug,info:info,info:warn,info:error,warn,warn:debug,warn:info,warn:warn,warn:error,error,error:debug,error:info,error:warn,error:error,debug,debug:debug,debug:info,debug:warn,debug:error}]
[–log-timestamp] [–local-timezone] [–log-no-colors]
[-G WEBHOOK] [–native-instruments-lib]
[–app-wait-package ANDROIDWAITPACKAGE]
[–app-wait-activity ANDROIDWAITACTIVITY]
[–android-coverage ANDROIDCOVERAGE] [–avd AVD]
[–avd-args AVDARGS]
[–device-ready-timeout ANDROIDDEVICEREADYTIMEOUT] [–safari]
[–device-name DEVICENAME] [–platform-name PLATFORMNAME]
[–platform-version PLATFORMVERSION]
[–automation-name AUTOMATIONNAME] [–browser-name BROWSERNAME]
[–default-device] [–force-iphone] [–force-ipad]
[–language LANGUAGE] [–locale LOCALE]
[–calendar-format CALENDARFORMAT] [–orientation ORIENTATION]
[–tracetemplate AUTOMATIONTRACETEMPLATEPATH] [–show-sim-log]
[–show-ios-log] [–nodeconfig NODECONFIG] [-ra ROBOTADDRESS]
[-rp ROBOTPORT] [–selendroid-port SELENDROIDPORT]
[–chromedriver-port CHROMEDRIVERPORT]
[–chromedriver-executable CHROMEDRIVEREXECUTABLE]
[–use-keystore] [–keystore-path KEYSTOREPATH]
[–keystore-password KEYSTOREPASSWORD] [–key-alias KEYALIAS]
[–key-password KEYPASSWORD] [–show-config] [–no-perms-check]
[–command-timeout DEFAULTCOMMANDTIMEOUT] [–keep-keychains]
[–strict-caps] [–isolate-sim-device] [–tmp TMPDIR]
[–trace-dir TRACEDIR] [–intent-action INTENTACTION]
[–intent-category INTENTCATEGORY] [–intent-flags INTENTFLAGS]

Node Server Process Ended

anybody know what might be the issue? I didn’t change anything in settings.



It looks like you may be using --intent-args without any args. Look at your command line and your desired capabilities.

Try to run the Appium as administrator.
This will solve your problem

I think you have enabled Launch Device from Android Settings of Appium Server.

  1. Open Appium Window.
  2. Click on Android Settings on the top left Corner.
  3. Go to Launch Device section
  4. Uncheck the Launch Device Check Box.
  5. Close and restart your Appium.

I think it will resolve your issue.

This is already unchecked

Even i am also facing the same issue please help me how to resolve

That is becaue your server arguments are missing an argument after the --log, you should add an absolute path to a file to save the server logs to it.

Something like:


Thanks, It worked for me !!!