Unable to swipe-up in iOS appium 1.3.1 version

Hi All,
In iOS swipe method(using python) is not working properly for me as
When I try to swipe down then its working fine below is code used

wd.execute_script(“mobile: swipe”, {“touchCount”: 1 , “startX”: 157, “startY”: 331, “endX”: 157, “endY”: 30, “duration”:1 })

But when I try for swipe up then its not working below is code

wd.execute_script(“mobile: swipe”, {“touchCount”: 0 , “startX”: 157, “startY”:30, “endX”: 157, “endY”: 331, “duration”:1 })

While executing above command then it just skipping
I am mad of how to do it
is there any other method we have for scrolling in iOS
can any one help me out

When I tried with Java scroll method is working fine but I need to check with python
Do we have any other method for swipe
please can anyone help me out …
I am struggling with this from past 7days
tried in 1.3.1 , 1.3.4 and 1.3.7 version of appium
Thank you

Same problem on iPhone6 and Appium 1.3.1 or 1.5.1.
Code: driver.swipe(driver.manage().window().getSize().getWidth()/4,
driver.manage().window().getSize().getHeight()/2, duration);

In latest 1.5.1 appium and latest java client swipe in iOS client working as


For example we have screen 300x500 and want swipe Up. Do swipe(150,480,0,-400,1000)