Wdio real device failed to creat webdriverAgent

when i use my Appium inspector, i open the app and get the elements.

but when i tried to use wdio and run a test, it failed!

[0-0] Testing failed:

[0-0] Signing for “WebDriverAgentRunner” requires a development team. Select a development team in the Signing & Capabilities editor.

[0-0] WebDriverAgentRunner:

We do not know:

  1. are you with real device or simulator
  2. with real did you complete https://appium.io/docs/en/drivers/ios-xcuitest-real-devices/ and how

Hi , it’s a real device but i rum it via xcode and got the WebdriberAgent in my iphone and i can run it via appium and get the element, but when i ran the test i got the fail of require development team

do you run from code same appium? e.g. you possible have Appium GUI and command line / terminal appium installed. they have different location. also you did not mention - did you add developer signature to WDA project?

how can i verify that it’s the same appuim? or change the terminal for the Appium Gui? mayby it’s the problem
i did a signature to WDA , i see it on my iphone and appium open it as well

rror: Failed to create session.
[0-0] An unknown server-side error occurred while processing the command. Original error: Unable to launch WebDriverAgent because of xcodebuild failure: xcodebuild failed with code 65
[0-0] xcodebuild error message:
[0-0] Command line invocation:
[0-0] /Applications/Xcode.app/Contents/Developer/usr/bin/xcodebuild test-without-building -project /Users/name/Documents/project/automation/node_modules/appium/node_modules/appium-webdriveragent/WebDriverAgent.xcodeproj -scheme WebDriverAgentRunner -derivedDataPath /Users/name/Library/Developer/Xcode/DerivedData/WebDriverAgent-fpcxhekuadghomboiwqohgswhiwi -destination id=b2f855a8bcd8ccfbf2e4a11f75cac2248b2ef179 IPHONEOS_DEPLOYMENT_TARGET=15.1 -xcconfig /var/folders/pc/z5xhnfnx50gch1jj8_ds5lv00000gn/T/202211-37793-o2p7jb.41mpo/appium-temp.xcconfig GCC_TREAT_WARNINGS_AS_ERRORS=0 COMPILER_INDEX_STORE_ENABLE=NO