We are experiencing max deep layer problem

Hi,

We have an app which is developed by react native and the app has a lot of layers. We are working on Mac. We examined, appium support up to ~62 layers and the app’s layers has much more than ~62. We gived 500 to snapshotMaxDepth for see all layers but appium stucks when start the app (emulator or real device), if we give 62 to snapshotMaxDepth the app is opened but we don’t see all layers. Also we tested Netflix app, we gived 500 to snapshotMaxDepth and we saw all layers.

We examined all relevant up-to-date source and we found some links for the issue but we couldn’t solved this problem, you can examine these links:


We saw locators in the app like below when we give 62 to snapshotMaxDepth.

Test FrameWork Version:
React Native: 0.71
Appium: 2.1.3 (and we tested appium 1 versions)
Appium Inspector Version: 2023.8.4
Electron: 13.6.9
Node.js: 14.16.0
XCode: Version 14.3 (14E222b)
Test Phone Platform Version: 16.3.1

We haven’t found a definitive solution yet. Should the application be rewritten from scratch, or should the layer structure in the application be edited, or is there a solution to this problem on the Appium side?

Are there any updates on this? Have you found a solution? Any feedback from the Appium Team?

1 Like

We have not found a solution yet, we are following this issue, as you can see, there is still no response from the appium team.
I hope they see this :slight_smile:

1 Like

Hello, did you got any solution?