WebDriver server for URL timed out after 60 seconds

I have problem with APPIUM C# client and Appium server. Before I used for testing Appium Python client and everything was OK. But now I switched on C# client.

When i’m trying create Appium WebDriver I get always this error -
New-Object : Exception calling “.ctor” with “2” argument(s): “The HTTP request
to the remote WebDriver server for URL timed out after 60 seconds.”
At C:\autolib\automation\lib\Cmdlets_Common\Appium.ps1:74 char:22

  • return New-Object <<<<  OpenQA.Selenium.Appium.AppiumDriver((New-Object u

ri($AppiumServerUri)), $capabilities)
+ CategoryInfo : InvalidOperation: (:slight_smile: [New-Object], MethodInvoca
+ FullyQualifiedErrorId : ConstructorInvokedThrowException,Microsoft.Power

This apk file has 12MB and test is running on virtual environment (WM) and on emulator, so It is possible that environment is slowed down that TimeOut 60 second for installation of APK is reached. But why didn’t I have this same problem with python client and my most important question - it is possible to change this timeout?

:frowning: thanks a lot


Navigate to this directory in your appium installation
and modify the following

this.defCommandTimeoutMs = this.args.defaultCommandTimeout;
this.commandTimeoutMs = this.defCommandTimeoutMs;

No idea why you did not have this problem when using python …



Hmm this is not working :-/ I have changed this value in Appium.js and Parser.js too (just for sure) and nothing, this same error. And in this error text is still “60 seconds” Any idea?

You can change that by using the following server configuration:

–command-timeout → The default command timeout for the server to use for all sessions. Will still be overridden by newCommandTimeout cap

The value is in milliseconds. Let me know how it works.


I know, I set it in miliseconds, but still nothing.

FIXED: New-Object OpenQA.Selenium.Appium.AppiumDriver((New-Object uri($AppiumServerUri)), $capabilities, (New-TimeSpan -Minutes 3)) <<< set longer timeout for constructor of driver.

I see the same error, can you please give more details is on how you resolved it,

OpenQA.Selenium.WebDriverException : The HTTP request to the remote WebDriver server for URL http://1xx.xx.xx:4723/wd/hub/session timed out after 60 seconds.

    capabilities.SetCapability(IOSMobileCapabilityType.LaunchTimeout, 160000);