WebDriverAgent cannot launch app

Hi, I am testing an iOS app, a month ago it worked great, came back from a vacation and for an unknown reason WDA is successfully installed on iOS simulator but cannot lunch the app under test.

The weird thing is that when I run my tests locally, everything works great and WDA successfully launches the app but, regularly I run the tests on a remote VM using Jenkins and for an unknown reason it does not work on this VM environment now(nothing changed during this month and both, local and remote environment setups should be the same as far as I am concerned)…
any ideas? suggestions? (same capabilities work on my local machine but not on the remote one, although it used to work on both).

Xcode version: 13.4
iOS version: 15.5 (Simulator)
appium version: 2.0.0-beta.46 (appium@next)

more info:

  • tried to re-install appium with xcuitest driver and yet, it did not work.
  • tried to build WebDriverAgentRunner project manually - the build succeeded and WDA app was successfully installed and still, it cannot launch the app when running the tests. I noticed that after the installation (when building WDA manually) Xcode shows a pop up message which says: “test failed” but it does not supply any information.
  • when enabling showIOSLog and showXcodeLog capabilities I observed the following error: xcodebuild exited with code ‘65’ and signal 'null’
  • tried to clean Derived Data folder, did not work as well.

will provide the logs if needed, any ideas for what else I can try?
Thank you ahead for any response!

It is hard to say anything without having the full log. From the above it looks like xcodebuild is unable to properly sign WDA because of some missing keychain entries for the particular jenkins agent. That also could be the reason the signing succeeds locally, but fails in CI env

1 Like

thanks for the response @mykola-mokhnach
I fixed it, still not sure what was the reason exactly.
for future documentation, my steps were:

  1. hard reboot the VM.
  2. reinstalling appium (more specifically, xcuitest driver).
  3. wiping Jenkins job workspace.