WebDriverAgent on Appium 2.0

Hi guys. I’m trying to run tests with appium 2.0 beta with ios real device.
But where is the folder with webdriveragent?
Or what the way to add wda to appium
Thanks in an advance

http://appium.io/docs/en/drivers/ios-xcuitest-real-devices/

My question was about appium 2.0 - i don’t see there webdriveragent

what you mean?

  • command line appium
  • GUI Appium

they both already 2.0 versions.

How you installing appium?

e.g. command line appium installed on mac has path to WDA:

/usr/local/lib/node_modules/appium/node_modules/appium-webdriveragent

oi…
command line appium version now is 1.22

i see 2.0 is older:image

I mean I know where for appium 1.22 placed appium-webdriveragent, but for appium 2.0 the folder is not there.

aga! looks like it need install first -> https://appiumpro.com/editions/122-installing-appium-20-and-the-driver-and-plugins-cli

I saw this article (generally i’ve used it as guide), but there is no info about webdriveragent

For any who see the same issue:
You can place you xcuitestdriver such as appium driver install xcuitest -ah Users//Desktop/appium2.0
And here will be placed your wda
Thanks Aleksei

1 Like

exactly! this is last part in guide:

Setting the driver repository location

/Users/$USER/.appium/appium-xcuitest-driver/node_modules/appium-webdriveragent

2 Likes

I installed Appium globally and then installed WDA via the command
appium driver install xcuitest
This was the location of WDA:
/Users/$USER/node_modules/appium-xcuitest-driver/node_modules/appium-webdriveragent

2 questions really I just tried to install version 2, instead of staying on 1.22 and I have to ask when is 2.0 going to go official roughly? My issue is the server is unable to find the drivers which are clearly installed when i ran

`appium driver list --installed
:heavy_check_mark: Listing installed drivers

it lists the driver, but a simple test script fails to find the drivers here altogether:
Original error: Could not find a driver for automationName 'XCUITest' and platformName iOS'. Have you installed a driver that supports those capabilities? Run 'appium driver list --installed' to see.