WebDriverAgent project file missing [SOLVED]

I got issue with run appium on real iOS device.
The issue is

Signing for “WebDriverAgentRunner” requires a development team. Select a development team in the project editor.
Code signing is required for product type ‘UI Testing Bundle’ in SDK 'iOS 10.0’

So I tried adding it to desired capability with config file.
Then I found there is a file missing with WebDriverAgent.
It is looking for RoutingHTTPServer/RoutingHTTPServer.h

Any help will be highly appreciated… :disappointed:

desired capabilities are like this,

you need to cd to the webdriveragent dir, and do

1 Like

It gives error like this
I had issue with ./Scripts/bootstrap.sh

ERROR in ./js/app.js Module parse failed: /usr/local/lib/node_modules/appium/node_modules/appium-xcuitest-driver/WebDriverAgent/Inspector/js/app.js Unexpected token (59:4) You may need an appropriate loader to handle this file type. SyntaxError: Unexpected token (59:4)

 **Update **  ----

Solved :smiley:

Following steps worked for me…

Cd usr/local/lib/node_modules/appium/node_modules/appium-xcuitest-driver/WebDriverAgent
brew install carthage
npm i -g webpack
./Scripts/bootstrap.sh -d

open /usr/local/lib/node_modules/appium/node_modules/appium-xcuitest-driver/WebDriverAgent/
run project

And solved sign in error with config file.

Thanks a lot… :bouquet:


If you get a error like "error: /usr/local/lib/node_modules/appium/node_modules/appium-xcuitest-driver/WebDriverAgent/Resources/WebDriverAgent.bundle: No such file or directory "

do this in terminal and then clean > build webdriver agent project in xcode.

mkdir -p /usr/local/lib/node_modules/appium/node_modules/appium-xcuitest-driver/WebDriverAgent/Resources/WebDriverAgent.bundle

1 Like