WebView, click on element and nothing happens

Hi, i am an appium newbie :slight_smile:

I am trying to run a test on iPad simulator, Hybrid app and latest Appium server (1.3.7).
I am clicking on an element and nothing happens.

Here is a sample test:

it("open contorl bar by click on it", function () {
  return driver
       .waitForElementById('controlbar0_outActionBar', 10000)

Already tried using nativeWebTap: ‘true’ (which helped when i run on Safari)

Please advise thanks

Hi @Shainter,

Could you please check if the element you are trying to click is in Native Context?
Then, you might switch to Native context and click on element.


@sujata_kalluri , Thanks for the response.

The element i am trying to click is in the WEBVIEW_1 context. i also printed the source to validate it.
If i am searching for it Native context, it fails since it won’t find it.

What i don’t understand is, why succeed to find it (e.g. using waitForElement…) but clicking on it does nothing

I did another try and while in Native context, i was able to perform click with XPath with:

I found this XPath using the Appium inspector. but the inspector won’t show a lot of other elements on the page.

Any idea what am i experiencing here?

Note: i am trying to interact with elements on top of HTML5 video . maybe it explain someting?

Thanks !

Hi @Shainter,

Could you provide any screenshot or the element HTML source so that we can have a better understanding?



While i was not able to solve the problem above, i encounter a new one:
I am able to click an element on Safari on simulator, but when i run on real ios device, click on some element do nothing (!)

I will appreciate any help to debug this.