Why can't the amount of «-- RAM of the Android virtual device --» be increased?

I tried to increase the amount of RAM of the device from the following 2 paths

Path one didn’t work:
Preferences > Appearance & Behavior > System Settings > Memory Settings

I set IDE max heap size to 4096
Also the values
Gradle daemon max heap size
And
Kotlin daemon max heap size
I set it to 2048, but it automatically returns to unknown-current mode

And the second route I tried:
Virtual device manager > Create Device > Virtual Device Configuration > Show Advanced Settings

But here the settings related to the amount of RAM were disabled

The third method I tried was to edit the Studio.vmoptions file and put this value in it (-Xmx4096m) but it still didn’t work.

And the last method I tried was the following trick, which made the virtual machine not work properly and crash

I generated a Pixel 2 image in the past and those values were locked to match the HW default of 1536 MB, so to edit them I had to “Show on disk” (from ADV manager) and edit the hw.ramSize keys in hardware- qemu.ini and config.ini

I have seriously tried all these methods and none of them worked! Does anyone know a solution!?

The amount of RAM memory of my virtual machines is 1536 by default and does not change :man_shrugging: Please help me :man_bowing: