Xcode build failed with code 65 in appium-desktop on real ios device

Here is the gist


@sarozNep, code 65 is usually triggers if the xcode project is not signed with proper developer certificate. I am not able to access the log file … please share the correct link to look into log files

I get the xcode failed error when app is installed already on the phone.

When app is not there i get

Encountered internal error running command: Error: Could not install app: 'Command 'ios-deploy … error …

i am not able to run the app or install it or test or i cannot even install webdriveragent in iphone … can u plz help me

Follow instructions in https://github.com/appium/appium/issues/9035#issuecomment-323005773 closely, it must solve your issue as well.



I have done full manual configuration for this. There is not even code signing issue. can you look in logs and tell me the issues …


exactly same problem is addressed in https://github.com/appium/appium/issues/7712

checkout solutions people have tried with latest appium server otherwise update ticket with all the details.


Your appium server version is quite old, update to latest 1.6.6-beta.4

i have already updated to Version 1.2.0-beta.3 (1.2.0-beta.3)… when i click update it says up to date

how to update it to latest 1.6.6-beta.4?? as i have already installed 1.2.0-beta.3 desktop version in my mac as application…

Latest release of Appium Desktop here:

This helped me after spending over 8 hrs trying to figure what was causing this issue.
Someone provided an answer over here. It helped me, maybe it can help you.

After specifying below capabilities, appium desktop worked. It would be good to have this documented somewhere:

“agentPath”: “/usr/local/lib/node_modules/appium/node_modules/appium-xcuitest-driver/WebDriverAgent/WebDriverAgent.xcodeproj”,
“bootstrapPath”: “/usr/local/lib/node_modules/appium/node_modules/appium-xcuitest-driver/WebDriverAgent”

UI Automator is not opening… In this release.

It worked for me, what error are you seeing?

I dont know … I cannot see this UI Automator when i start session… device is opening the app but i cannot see UI automator

Hey !! i am really having trouble with this. I need to inspect the element. Can u tell me the full procedure to make this happen ? please

Do you see any error in logs or on screen?

Can u just tell me the procedure ?

Can you the try the steps in this video and check if it helps:


If you are on Mac, can you open your Terminal > type this command and share the output here?

appium -v