Xcode version '0.0'. Support for Xcode 0.0 is not supported. Please upgrade to version 7.3 or higher


#1

Problem:
Xcode version ‘0.0’. Support for Xcode 0.0 is not supported. Please upgrade to version 7.3 or higher

Please help to find solution


#2

Upgrade the server (preferably to [email protected])


#3

Yes, upgraded and it is working thank you:)


#4

could you please tell me how?


#5

Hi Daad_abdullah,

Upgrade your appium server to 1.9.0 through npm and restart your machine it should work


#6

thanks Dayanand , but it did not work, I upgraded the appium through terminal and checked it is 1.9.0 then Restarted my machine. same error occur after running the code in eclipse.


#7

could you paste here the capabilities used in your script and did you configured provisional certificate ??


#8
    dc.setCapability("platformVersion", "12.0");

    dc.setCapability("platformName", "iOS");

    dc.setCapability("deviceName", "iPhone x");

    dc.setCapability(MobileCapabilityType.BROWSER_NAME, "Safari");

dc.setCapability(MobileCapabilityType.UDID, “E3C0BF34-2C02-4CDA-A9C2-DE4F6CC88AA9”);

what is provisional certificate ?


#9

To create provisional certificate please follow below link:
https://clearbridgemobile.com/how-to-create-a-distribution-provisioning-profile-for-ios/
this is used to register device through developer account and it will communicate with xcode and help user to run ios scripts.

you are missing 3 important capabilities i.e.
xcodeorgid:
bundleid
xcodeSingningid

please use these three capabilities in your scripts just google in those three capabilities and use it if u face any problem please feel free to update here


#10

thanks a lot . but is not this for making apps ?
I am just trying to automate testing using a simulator