Xcodebuild failed with code 65 (WARNING: The server did not provide any stacktrace information) Command duration or timeout: 32.63 seconds

@vani.hosagoudra: Appium 1.6 beta is outdated, i highly suggest you to go ahead and download the appium 1.6 final version. In appium 1.6 the Xpath are being changed as required in backend.

Thanku soo much for support…I found only 1.5.3 appium in appium.io sight.Where do i find 1.6 version appium? is appium 1.6 supports inspector? if not which one to use for element inspection?


Thanks soo much…I am able to find the xpaths using print page source…But this process is tidious
and chances of missing tags…So any other inspector tools?

@ pavanbachu
can you please tell me where to get appium 1.6 and how to install?

Is this command failing for everyone else as well? Seems to be giving me a 404

Installation : npm install -g appium

Appium Inspector : https://github.com/mykola-mokhnach/Appium-iOS-Inspector clone the workspace and you can use that…

Hi guys,
Can any one please teach me how to find out the xpath in the below page source.

I need to find the xpath for the element in the “XCUIElementTypeCell”…

<?xml version="1.0" encoding="UTF-8"?> <**_XCUIElementTypeCell_** name="" label="" value="" dom="" enabled="true" valid="true" visible="true" hint="" path="/0/0/0/0/0/0/1/0/0/1/0" x="8" y="230" width="70" height="70"> pageSourceCode.txt (9.8 KB)

You need to follow the hierarchy and their index to create this.

This can be xpath for the first back button on your screen.

This can be xpath for the first done button on your screen.

I hope this helps…

1 Like

Thanks for the help…
I am unable to trace t he inner tags…for example if a tag closes before any other tag do i need to consider or not?
So if u give me xpath for XCUIElementTypeCell tag i will analyse and understand

Thanks in advance



probably this…

Hi @pavanbachu,
I was installing carthage but getting following error:
Please help:

$ npm install -g carthage --HEAD
npm ERR! Darwin 16.1.0
npm ERR! argv “/usr/local/Cellar/node/6.8.1/bin/node” “/usr/local/bin/npm” “install” “-g” “carthage” “–HEAD”
npm ERR! node v6.8.1
npm ERR! npm v3.10.8
npm ERR! code E404

npm ERR! 404 Registry returned 404 for GET on https://registry.npmjs.org/carthage
npm ERR! 404
npm ERR! 404 ‘carthage’ is not in the npm registry.
npm ERR! 404 You should bug the author to publish it (or use the name yourself!)
npm ERR! 404
npm ERR! 404 Note that you can also install from a
npm ERR! 404 tarball, folder, http url, or git url.

npm ERR! Please include the following file with any support request:
npm ERR! /usr/local/lib/node_modules/appium/node_modules/appium-xcuitest-driver/WebDriverAgent/npm-debug.log

$ cd /usr/local/lib/node_modules/appium/node_modules/appium-xcuitest-driver/WebDriverAgent/
$ npm install -g carthage --HEAD
$ open .

This is the location where the webDriver agent is saved check if you have webdriver agent xcode project. It should look like this :

open the xcode project and follow the below steps for the creating the xcodeConfigfile which is at bottom in the image

  1. Open the existing the WebDriver Agent
  2. On top of Xcode you File > New> File , then you will an pop up something like this
  3. Select OSX->.Other-> Select Configuration settings file.
  4. Paste the following things in newly created file.
    DEVELOPMENT_TEAM = xxxxxxxxx
    CODE_SIGN_IDENTITY = iPhone Developer
    Development team is Team ID which your developer should be able to provide . Dont change the CODE_SIGN_IDENTITY.

Once you save the file , make sure you add this file as a capability in your java code .

Please follow these steps
after that add xcodeConfigFile=file path here and capabilities.setCapability(“xcodeConfigFile”,deviceProp.getProperty(“xcodeConfigFile”));


That is the issue: my present working dir. is →
only, and when i am calling the installation command it is showing the above errors

when in tried using “brew install cathage” it installed it in other location “/usr/local/Celler” even the copy past of “Carthage” folder from “/usr/local/Cellar” to “/usr/…/WebDriverAgent” is not working.

please help

Have u tried in this way?
go to the terminal and then go to this folder…like below
$ cd /usr/local/lib/node_modules/appium/node_modules/appium-xcuitest-driver/WebDriverAgent/
$ npm install -g carthage --HEAD
$ open .
This is the location where the webDriver agent is saved check if you have webdriver agent xcode project.

Thanks for the reply @vani.hosagoudra

Yes i have tried that way only, went to the path : “/usr/…/WebDriverAgent”, then called -> $npm install -g carthage --HEAD, after which i received that errors. Yes i have “WebDriverAgent.xcodeproj” in the WebDriverAgent folder.

Please help.

what is the path of ur WebDriverAgent folder?


All these present in this directory?

Yes i have tried that way only…these files are present there…

before installing carthage… try these commands in the terminal
brew install ideviceinstaller
npm install -g iso-deploy

after that use cd and go to web driveragent folder and try