Appium 1.8.0 Release


#1

Appium 1.8.0 introduces full support for the W3C WebDriver specification
(digested version of the spec).

General

  • Minimum NodeJS version moved to 6
  • Add methods for
    • getting and setting the clipboard contents
    • get full screen screenshots
    • Application management
  • More efficient app downloading by caching URLs
  • All moveTo operations in touch actions now take coordinates as absolute
  • Support for registering selenium grid through HTTPS by setting the configuration
    key "hubProtocol" to "https"
  • Add otherApps desired capability, to specify array of ancillary apps to install
    on session creation

iOS

  • Support for iOS 11.3/Xcode 9.3
  • Fix handling of process arguments
  • Add capabilities
    • shutdownOtherSimulators - shutdown other running simulators at session start up
  • Add ability to record screen
  • Add support for complex gestures
  • Fix handling of custom SSL certificate on simulators
  • Better handling of xcodebuild processes
  • Maintain keychains while upgrading apps
  • Better handle simulators in unexpected states
  • Add performance measuring (see documentation)

Android

  • Support for Android P (API Level 28)
  • Fix handling of webview contexts when resetting apps
  • Fix handling of screen recording
  • Make sure intent is broadcast when file is uploaded
  • Add possibility to broadcast device logs through WebSocket
  • Chromedriver
    • Bundle version 2.37
    • Automatically choose compatible Chromedriver for Chrome version
      • chromedriverExecutableDir capability to specify where Chromedrivers are located
      • chromedriverChromeMappingFile capability to specify what Chromedriver version corresponds to what Chrome version
  • Fix Handling of idle state waiting
  • Speed up screenshot logic in UiAutomator2
  • Allow disabling of notification watching through settings
  • Fix parsing and granting of permissions for app under test
  • Support deep linking and Android Instant Apps

Appium iOS issue with automaitionName capability
pinned globally #2

#3

I am unable to apply with this build. You can find the logs below.


#4

Guys, any introduction about this setting?


#5

I think that refers to this PR (https://github.com/appium/appium-uiautomator2-server/pull/111)

You can explore it by using the tests they implemented, such as https://github.com/vmaxim/appium-uiautomator2-server/blob/master/app/src/test/java/io/appium/uiautomator2/model/NotificationListenerTests.java

The settings enableNotificationListener is in documentation in here: http://appium.io/docs/en/advanced-concepts/settings/#supported-settings


#6

There was a very informative webinar on this release from Jonathan himself.

Do wattch with your team

https://info.perfectomobile.com/appium_w_jonathanlipps_odw.html


#7

Hey :slight_smile:
can you publish the appium REST server endpoints?
thanks!


#8

is there any documentation regarding screen recording?


#9

For Java-Client you can check:



#10

Hello,

When we can expect appium 1.8 dmg for mac, I am facing a problem, my all iPhone devices updated to 11.3 and now i unable to run appium on it i also tried with install globally but its not performing click. just launch the app.But script working fine with 1.7.2 appium on 10.3 ios version


#11

You have dmg for appium-desktop (https://github.com/appium/appium-desktop/releases).

To automate iOS11.3 I think you should have appium 1.8 and XCode9.3


#12

Appium 1.8 dmz not available on that release note .
yes i already have xcode 9.3 and appium 1.8 (Globally installed by npm) but still not working.
For make sure the element i have to use appium inspector which can be use in dmg


#13

Open a new topic with the your code and logs from appium.


#14

I had an issue with Appium 1.8 version after completing the tests in the result it shows test fail i think when it will try to open app again it’s browser exception.


#15

Probably over this weekend. But you can use 1.8 from the command line and use the Inspector with it still.


#16

Hi,
I tried your code in my project, but it does not work - startRecordingScreen() method does not exist. I’m using Appium version 1.8.0. What could be wrong?

Cheers, Ziga


#17

Its not my code :slight_smile: Its the code used to test the java client.

Make sure you are using the latest java client.


#18

Oh, I see it comes with Appium Java client 6.0.0-BETA3. Thanks


#19

With command line 1.8 its shows error
“Returned value cannot be converted to WebElement on iOS 11.3 with Appium 1.8.0
Issues/Bugs”


#20

@pushpank I am facing the Same Issue(Returned value cannot be converted to WebElement) and when I tried to Down grade it to 1.6.1 It is Showing 1.6.1 in the when i tap “About Appium” from menu on the mac.When i check for Updates its saying “up to date”.Let me know if you could be able to resolve some how Thanks.