sendKeyStrategy issue on 1.3.3 and beyond (real iOS device)


It looks like beginning 1.3.3, sendKeyStrategy has been introduced and is part of Desired Capabilities. I was on 1.3.5 and now in 1.3.6 and it seems that sendKeyStrategy is buggy. I’m automating an iOS native app on iPhone 6 device and we need to login to the app with user id and password. Every time, I tried to do sendkeys/setValue, the value is being set but not in the usual means. I tried to edit the text that I set thru automation in the text field while the code is in break point mode and I’m not able to do so.

Checked the appium log reveals that the sendKeyStrategy is set to “grouped” which is like typing the text all at once which isn’t working. I changed this to “oneByOne” and isn’t working. I also tried setting it to “setValue” and used both sendKeys and setValue and all exhibit the same behavior.

I can downgrade to 1.3.1 which seems to not have the sendKeyStrategy at all which is working perfectly but don’t want to miss the fixes and new additions to the 1.3.4, 1.3.5 or anything beyond.

Can we get a quick fix for the default “grouped” on a physical device as “grouped” seems to be the fastest one.


please open a bug

refer to File Appium Bugs on GitHub