TouchActions doesn't work properly with appium server 1.5.1

Recently I’ve started to move to new appium server , but I’ve some issues with already implemented TouchActions gestures , in Appium 1.4.16 + java_client 3.4.1 the code I’ve works , but while I’m running it against Appium 1.5.1 nothing happens , no execption being thrown , just nothing correct happens (the swipe direction is wrong)

Has anyone tackled with the issue ?


iOS or Android? code example?

iOS 9.1

int x = elem.getLocation().getX();
int width = elem.getSize().getWidth();
int y = elem.getLocation().getY();
int height = elem.getSize().getHeight(); + (int)(width * 0.75), y + (int)(height * 0.1)).waitAction(600).moveTo(elem, 0, 0).release().perform();

As I said, in 1.4.16 everything works fine (the object being swiped from right to left, but in appium 1.5.1 from some reason the element being swiped from up to down

i mentioned that Swipe in latest appium with iOS working with RELATE coordinates. Maybe here also?

give a try with “moveTo(relative_X, relative_Y)”

tried , but doesnt work either

according to appium code swipe =

        TouchAction touchAction = new TouchAction(this);, starty).waitAction(duration).moveTo(endx, endy).release();

and it is working for me (with only difference that ‘end’ is relative) with 9.3 xCode, appium 1.5.1, java-client 3.4.0

maybe remove “perform()” :frowning:

Didn’t help …

probably I’ll continue to use with the old version for meanwhile :frowning:

It also worked for me before I’ve upgraded the Appium server …

The thing is, that the move being performed only vertically (on Y axis) no matter which parameters I send to X’s end pont

I also observed this behavior with swipe() method, the issue is that a move is performed vertically.
My test environment is: iOS 9.3.1, appium 1.5.1, Appium_Python_Client-0.13, xCode 7.3.

Issue already discussed here

I’m confused now, was it reversed in purpose ? or it’s just an appium bug ?
If it’s a bug , then the issue is marked as closed for appium 1.5 , and I’m using appium 1.5.1 and still have the strange behaviour , if it’s not a bug, then what was the idea of the change ? (against the all familiar way…)

Don’t know why Appium 1.5 introduced this behavior, but you could fix it on client side by overriding swipe method.

Solution described [here for #350] ( works. You will notice that move_to needs adjustment.