[WebDriverAgent] No WDAs on the device

I am getting this issue while running the appium on an IOS device.

While automating the IOS Apps I am getting the below issue

Failed to create a session. An unknown server-side error occurred while processing the command. Original error: Unable to launch WebDriverAgent because of xcodebuild failure: xcodebuild failed with code 65 xcodebuild error message:

Platform. : IOS
Device: iPhone 14 /Any Apple device
Appium Version. : 1.22.0 ( Tried with the latest version also )
Xcode Version: 14.2( tried with latest version also)
My local Device: Mac Book Pro (Mac OS: Ventura 13.2.1)

Desired Capabilities :

“platformName”: “iOS”,
“appium:platformVersion”: “16.4”,
“appium:deviceName”: “iPhone 14”,
“appium:bundleId”: “com.apple.Health”,
“appium:udid”: “4A0EEB47-98C9-435B-BB11-98E5596065A5”

I have also tried to change the signing certificate but getting the below issue

Even if I click on unlock, it does not unlock the project. Instead, it keeps on popping up the same unlock message.

you can check this: Can't connect Appium inspector to iOS Simulator (65 xcodebuild error message)
looks the same, you have appium version below 2 and xcode version above 14 so probably as he mentioned, upgrading to appium2 solved his issue.

you can try to build it manually as well, follow this: https://github.com/appium/appium-xcuitest-driver/blob/master/docs/wda-custom-server.md#wda-setup (deprecated)
new link: https://appium.readthedocs.io/en/latest/en/advanced-concepts/wda-custom-server/#:~:text=In%20order%20to,the%20main%20menu

And in general, I am sure there are many posts about this exact issue, you can search for them.

I think you will be better off using Appium 2 with Xcode 14:

1 Like

Hi Wreed,

Thanks a lot, This link helped me to fix the issue.

In addition to the above, I followed the below steps.

Also for installing XCUITest I had to downgrade the npm version to 6 using the below command:
npm -g install npm@6

After installing XCUITest and UIAutomator2 driver, to start the Appium upgrade the npm to the latest version

Then in the appium inspector remove ‘/wd/hub’ from the Remote Path text field, keep the field blank and click on the ‘Start Session’ button to launch the app.

1 Like