Could Not Launch Appium Inspector Xcode 8, appium 1.5.3 [SOLVED]

I cannot launch Appium Inspector…

macOS Sierra version 10.12(16A323)
Appium v1.5.3
Xcode Version 8.0 (8A218A)

When I launch Appium Doctor, Every thing is fine…

In terminal,

When I get Appium Inspector,

I have given app path for

Error is shown,

Is this due to incompatibility of Xcode 8 with Appium 1.5.3 ?
How can I solve this issue?

if you have xcode8 you need to use appium 1.6.3 and use xcode accessibility inspector instead

Thanks for reply.

in here ,

it is said that

But appium does not provide inspector for XCUI yet. It is only server 1.6

I’m now following the steps provided in the link.
Not sure whether it is going to work.

As I see you installed the appium server equal or more than 1.6.0. That’s fine.
But you are still run the 1.5.3 server from the appium desktop.
What should you do:

  1. stop the appium server on desktop version - No logs should be in desktop version;
  2. leave running server from the terminal.
  3. run the inspector from appium desktop - just click on the magnifying glass icon - logs should appeared in Terminal where you have ran appium server 1.6.1-beta.

Kind Regards,

Did it, but cannot launch.
Could not start a new session

The log is as follows.

[iOS] SessionNotCreatedError: A new session could not be created. Details: Appium’s IosDriver does not support xcode version 8.0. Apple has deprecated UIAutomation. Use the “XCUITest” automationName capability instead.

I’m on 1.6.3 on Sierra 10.12.2 I’m using the one that the Macaca team created.

1 Like

Thanks a lot for link.

I got first option and it is working… :grin: :smile:

Macaca didn’t give the link.
Could not launch app inspector…
I’m still trying to make it fine.

It gave error like this

>> app-inspector:66:44 [master] pid:6570 undefined

I’m fine with 1st option, thanks…

Kill it and rerun it. It does that.

:grin: :relieved:

Yes thats it…
Thanks a lot :bouquet:

I killed the server many times but no luck.Still I am getting the below error when I tried to use macaca.

app-inspector -u

xctest-client start with port: 8900
WebDriverAgent version: 1.0.41
app-inspector:66:44 [master] pid:9875 undefined

Can some one please help me on this.Thanks in advance.

Open terminal > type killall node > enter
Then start macaca again.

It worked for me

I had the same problem. It worked when I did the following.

Go to the folder where package.json exists.(/Applications/

Run the following command

     npm install appium-xcuitest-driver

Once done. Run Appium from command line and then open the Appium Inspector from the GUI.

I am not able to find the folder as appium under node_module

It should be under


Whats the issue you are facing?
Have you tired with latest version ?

@Sandarekha here are the details of the Appium version : Appium v1.6.1
I installed app inspector as per below blog:

when I am starting the app inspector with my iPhone as
app-inspector -u xxxxxxxxxxxxxxxxxxxx

This is the console output:

xctest-client start with port: 8900
WebDriverAgent version: 1.1.6
app-inspector:66:44 [master] pid:1984 undefined
(node:1984) UnhandledPromiseRejectionWarning: Unhandled promise rejection (rejection id: 1): Error: >> app-inspector:66:44 [master] pid:1984 undefined
(node:1984) DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit code.

Try this link

And Why dont you move to latest version of appium desktop app?
They provide app inspector with latest version.

I had tried with latest version earlier but I was getting some error so I again installed 1.6.1. I don’t remember the exact error.

Let me check this link, otherwise I will switch to 1.6.4 again

Do you mean latest version as 1.6.4?

This one

I uninstalled appium and trying to install using npm install -g [email protected]
But it seems appium hanged at one point i.e.
⸨ ░░░░░░░░░░░░░░⸩ ⠹ loadRequestedDeps: sill install loadAllDepsIntoIdealTree

I tried clearing cache using npm cache clear.

I did npm install --verbose which is giving info as below:
npm WARN enoent ENOENT: no such file or directory, open ‘/Users/myuserid/package.json’
npm verb enoent This is most likely not a problem with npm itself
npm verb enoent and is related to npm not being able to find a file.
npm verb enoent
npm WARN myuserid No description
npm WARN myuserid No repository field.
npm WARN myuserid No README data
npm WARN myuserid No license field.

So I am stuck installing Appium 1.6.4 and No idea about package.json.
Do I need to create this file manually?